Ubuntu 18.04 lxd和lxd-client导致版本过低无法apt安装

  • A+
所属分类:Linux

导致原因:升级apt install upgrade导致lxd-client版本被拉低到1:0.8导致无法安装lxd版本1:0.8,如下图,正常情况lxd-client和lxd版本是一样的。非必要情况下不建议去升级。

检查lxd和lxd-client版本

dpkg -l | grep lxd
Ubuntu 18.04 lxd和lxd-client导致版本过低无法apt安装

顺带讲下Linux中update和upgrade有何区别?

update

update 是同步 /etc/apt/sources.list 和 /etc/apt/sources.list.d 中列出的源的索引,这样才能获取到最新的软件包。

upgrade

upgrade 是升级已安装的所有软件包,升级之后的版本就是本地索引里的,因此,在执行 upgrade 之前一定要执行 update, 这样才能是最新的。

解决方案(仅供参考)

用dpkg离线重装lxd-client(及lxd)至3.0.3版本并锁定版本

lxd-client下载地址,也可以去官方搜索,如图

Ubuntu 18.04 lxd和lxd-client导致版本过低无法apt安装

下载到root目录下赋权安装

sudo chmod +x lxd-client_3.0.3-0ubuntu1_18.04.1_amd64.deb

安装离线包

sudo dpkg -i lxd-client_3.0.3-0ubuntu1_18.04.1_amd64.deb

锁定lxd及lxd-client版本

echo "lxd hold" | sudo dpkg --set-selections
echo "lxd-client hold" | sudo dpkg --set-selections

修复apt

sudo apt -f install
Ubuntu 18.04 lxd和lxd-client导致版本过低无法apt安装
  • 博主微信
  • 这是我的微信扫一扫
  • weinxin
  • 运维交流群
  • 扫一扫二维码加入群聊
  • weinxin

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: